DIT | Static and default routing configuration and explanation


2.1   # STATIC AND DEFAULT ROUTING WITH PRACTICAL LAB

Routing configuration is that join multiple networks together. Technically, a router is a layer 3 device, meaning that it connects two or more network and that the routing to operates at the network layer of the OSI model. By maintaining configuration information in pieces of software called the routing table. The term routing is used for taking a packet from one device and sending it through the network to another device on a different network.
If your network has no routers then it should be apparent that you are not routing. Routers route traffic to all the networks in you internetwork. To be able to route packets, a router must know, at a minimum following:

• Destination address
• Neighbor routers from which it can learn about remote networks
• Possible routes to all remote networks
• The best route to each remote network
• How to maintain and verify routing information

# There are all types of routing and mentioned below : -

1) STATIC routing : It is not a routing protocol; instead, it is the manual configuration and selection of a network route, usually managed by the network administrator. And it also gives a Source and Destination defines. Benefits: There is no bandwidth use between the routers. Which means you could possibly save money on WAN links. And its add security because the administrator can choose to allow routing to certain networks only.

Advantage : This list describes each command in the string.

a) IP route : The command used to create the static route.
  ip route   [prefix mask]   [ip address]

b) Destinatione Network : The network you’re placing in the routing table.

c) Mask : The subnet mask being used on the network.

d) Next-hop address : The address of the next-hop router that will receive the packet and forwards it to the remote network. This is a router interface that’s on a directly connected network. You must be able to ping the router interface before you add the route. If you type in the wrong next-hop address, the static route will slow up in the router’s configuration but not in the routing table.

e) Exit-interface : Used in place of the next-hop address if you want and shows up as a directly connected route.

f) Hop: Movement of packet between the networks.

g) Administrative Distance : An administrative distance is the metric used by routers to choose the best path when there are two or more routes to the same destination from two different routing protocols. An administrative distance guides the selection of one routing protocol (or static route) over another, when more than one protocol adds the same route to the unicast routing table. Each routing protocol is prioritized in order of most to least reliable using an administrative distance value.
Static routes have a default administrative distance of 1. A router prefers a static route to a dynamic route because the router considers a route with a low number to be the shortest. If you want a dynamic route to override a static route, you can specify an administrative distance for the static route. For example, if you have two dynamic routes with an administrative distance of 120, you would specify an administrative distance that is greater than 120 for the static route if you want the dynamic route to override the static route. And use to find the reliability (Ratio of error packet to the total number of packet of the root bridge).

h) Bidirectional Forwarding Detection (BFD) : This feature supports bidirectional forwarding detection (BFD) for IPv4. BFD is a detection protocol designed to provide fast forwarding-path failure detection times. BFD provides subsecond failure detection between two adjacent devices and can be less CPU-intensive than protocol hello messages because some of the BFD load can be distributed onto the data plane on supported modules.

Syntax of static routing : -
ip route   [Destination_network]   [mask]   [next-hop_address or exit interface]   [administrative_distance]

i) State and explain IP – Routing
It is the process in which ip – packets delivered from one device in a network to a device in other network. The router must know following things before routing a packet to destination.

I) Address of the destination machine. And Details about neighboring routers, which provide the information about remote network.
II) Best route that is possible to remote network.
III) All the information is stored in routing table.

Routing protocol : -
* Allow routers to dynamically advertise and learn routes.
* Determine which routes are available and which are the most efficient routes to a destination (Define the best and shortest path).
i.e. RIP, OSPF, IGRP, EIGRP, IS – IS and BGP.

Routed protocol : -
* Data being transported across the network.
* Sent the packet /flow the data / Used to support data traffic
i.e. Internet protocol, Novell IPX, DEC net, AppleTalk, Banyan vines Xerox Network system (XNS)

Disadvantage: It is not feasible in large network because cause maintaining it would be a full time job itself.

2) DEFAULT routing : We use default routing to send packets with a remote destination network not in routing table to the next-hop router. When attempting to reach a Network or computer doesn’t know how to reach and which is not on the local network, then that network quires goes to last of resort default gateway so use default routing to send packets with a remote destination network not in routing table to the next-hop router. It gives Source define only is known as Default routing (Stub network).
To configure a default route, you will use wildcards in the network address and mask location of a static route. In wildcard masking One (1) means Don’t care and Zero (0) means Must match.




2.2   # STATIC n DEFAULT COFIGURATION (Practically) :-
# Static and Default Configuration Lab : -
1) Configuration of router_1

hostname Side_A
!
interface tenGigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
no shutdown
!
interface Serial1/0
ip address 10.10.10.1 255.255.255.0
encapsulation hdlc
clock rate 9600
no shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.11.1
ip route 192.168.10.0 255.255.255.0 Serial1/0
ip route 192.168.11.0 255.255.255.0 Serial1/0
!


2) Configuration of router_2
hostname Side_B
!
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
! interface Serial1/0
ip address 10.10.10.2 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1
ip route 192.168.1.0 255.255.255.0 Serial1/0
ip route 192.168.2.0 255.255.255.0 Serial1/0
!

# Troubleshooting:
Router (config) #show arp
Router (config) #show ip route
Router (config) #show protocols
Router (config) #show interface fa 0/0




Be updated into yourself and improve lives through DIT

Post a Comment

0 Comments